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1 Introduction 

1.1 Purpose and Scope 

Describes how to test a batch of AOSEMs for electronic noise using the LHO BSC test stand. 
Could be used with minor modifications to test AOSEMs on any other other test stand or 
production system. 

1.2 References 

E1101030: AOSEM Noise Test Data 
S1106179: Template for more AOSEM S-number documents. 
T1000100: Parametric Study of AOSEM Sensor Noise 

G1100856: bOSEM Satellite Amp Saturation 
https://awiki.ligo-wa.caltech.edu/aLIGO/Suspensions/TestStands: Wiki page with additional 
information about the computers at the test stand.  

1.3 Version history 

10/10/11: Pre-rev-v1 draft. 
10/16/11: -v1. Near-final version for trying out with Jeff Bartlett. 

10/24/11: -v2. Refined version with new open light measurement procedure, corrected SVN 
procedure, more computing details, max and min open light requirements. 

2 Theory 

2.1.1 Noise 

The noise requirement for AOSEMs was set by their use in the IO suspensions and derived by 
David Reitze (email to Norna Robertson, 2/8/10). It is plotted in Figure 1, and the data file for the 
plot is in the associated documents for this report, as well as on the SUS SVN at 
^/trunk/electronicstesting/AOSEM/noise/HA_sense_noise.txt. 

To relate this displacement noise requirement to a measurement in counts/√Hz on the test stand 
requires chasing the chain of mechanical and electrical calibration factors. 
Per T1000100, a typical AOSEM had a open light (maximum) photocurrent of 30 µA, and 
mechanical conversion factor of 0.05 A/m. If we assume that the shape of the curve in Figure 2 of 
T1000100 is representative but that different AOSEMs have different open light currents, this is 
conveniently expressed as a conversion factor scaled to open light of 1666 m-1.  
Per G1100856, satellite amplifiers will be retrofitted to have gain resistors of 120 kΩ. Thus the 
transresistance from the photocurrent to the two-sided differential output signal will be 240000 
V/A. 
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The whitening filter has non-unity gain at higher frequencies, but if the software dewhitening filter 
is engaged, this is cancelled accurately enough for the present purposes. 

The 16-bit ADC takes a 40 Vpp two-sided differential input and maps it onto 2^16 values, for a 
response of 1638.4 counts per V. 

The average open light counts for the 12 AOSEMs in batch 2011-10-13-01 was 20926. This 
implies an average open light photocurrent of 20926/1638.4/24000 = 53.2 µA or multiplying by 
1667 m-1, a mechanical sensitivity of 0.0887 A/m. However we choose a nearby round number and 
define a nominal AOSEM as having 20000 counts or 50.9 µA at open light, and a mechanical 
sensitivity of 0.0848 A/m. 
Finally, the scaling factor to metres from counts for any AOSEM is 1/1667/(open light counts), 
which is 3.00x10-11 m/count for a nominal AOSEM. 
The above is implemented in the Matlab function processbatchdirectory.m described in 
the procedure section below. The function is intended to be run in the 
^/trunk/electronicstesting/AOSEM/noise directory of the working copy of the SUS 
SVN on the test stand. It looks in a subdirectory specified by a string argument for a noise data file 
saved from DTT, and generates noise plots for each of the AOSEMs in the batch with the 
requirements curve superimposed. 
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Figure 1: AOSEM noise requirement 



Advanced LIGO LIGO-E1100860-v2 

 5 

2.1.2 Open light voltage 

The test stand electronics has a component (probably the AA chassis) that saturates at around 
30000 counts, so that AOSEMs that give more output that that cannot be tested for noise. Also 
some AOSEMs have inconveniently low output. We set provisional minimum and maximum open 
light count values of 15000 to 30000. 

3 Procedure 

3.1 Set-up for one or more batches 

Most of the computing steps in this section affect the workstation and could be done most simply 
sitting in front it. However they are probably best done indirectly from the iMac, to save garbing 
and ungarbing, and this is how the instructions are written. See the wiki for more information on 
computing tips and techniques. 

1. Open a Terminal window (click on the Terminal icon in the Dock and choose Shell->New 
Window->Basic) and log in to the front end with the following command (there should also 
be a Dock icon called “Terminal (Front End)” or the like to do both of these in one click): 

> ssh -X controls@bscteststand2 

2. Check what modules are running: 
> lsmod 

3. Check that the module x1susquadfe is in the resulting list. If not, continue at Step 7. 

4. Check if x1susbsfmfe is in the list – if so kill it: 
> killx1susbsfm 

5. Start the quad model: 
> startx1susquad 

6. In the front end directory /opt/rtcds/tst/x1/chans/daq/, backup the file 
X1SUSQUAD.ini by renaming it to something appropriate (perhaps to include the date) 
and make a copy of X1SUSQUADminimal.ini as X1SUSQUAD.ini. 

7. Log into the daqd command line: 
> telnet localhost 8087 

8. Check that you get a prompt daqd> 

9. Kill the daqd process: 
daqd> shutdown 

10. The daqd process should quit, the telnet session will be terminated, and the daqd process 
should be automatically restarted. 

11. Open a second Terminal window (again, click on the Terminal icon in the Dock and choose 
Shell->New Window->Basic) and log in to the workstation with the following command 
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(there should be a Dock icon called “Terminal (Workstation)” or the like to do both of these 
in one click): 

> ssh -X controls@10.11.0.96 

12. Open the MEDM quad main screen with the following command in the Terminal window 
with the workstation login session from the previous step (alternatively, there should be a 
Dock icon called MEDM): 

> medm -x /opt/rtcds/tst/x1/medm/x1susquad/X1SUS_CUST_QUAD_OVERVIEW.adl& 

13. Bring up “X1SUSQUAD GDS TP” screen by clicking on the button. On that screen, click 
“BURT” and “Coeff Load”. 

14. Do a BURT backup of the MEDM state. See the wiki for detailed instructions. 
15. Back at the X1SUS_CUST_QUAD_OVERVIEW screen, open all OSEM INPUT FILTER 

screens (for M0, R0, L1 and/or L2) that have AOSEMs connected to associated channels.  
16. Check (i) that all LHS ON/OFF switches are ON, (ii) all RHS ON/OFF switches are off (for 

safety), (iii) all offsets are 0, (iv) all gains are 1.0, and (v) all FM1 filters are enabled 
(double green). 

17. Leave MEDM open for recording open light counts below. Leave the front end and 
workstation terminal sessions open. 

3.2 Procedure for each batch 

Many of the comm 

1. Select up to 20 AOSEMs for testing. 
2. In the Terminal window with the workstation login session, navigate to the AOSEM 

directory (if you’ve just finished testing a prevous batch, you should have been brought 
back there already): 

> cd /ligo/svncommon/SusSVN/sus/trunk/electronicstesting/AOSEM/noise 

3. Make a copy of the subdirectory yyyy-mm-dd-bb, replacing yyyy etc by the year, 
month, day and batch number for the day. Hereafter this will be called the batch directory. 

> svn copy yyyy-mm-dd-nn 2011-10-13-01 

4. Go into the batch directory,: 
> cd 2011-10-13-01 

5. Open the file AOSEM_Batch_Index.xls with Open Office (this will be called the batch 
index): 

> ooffice AOSEM_Batch_Index.xls & 

6. Connect the AOSEMs up to the OSEM cables on the quad test stand. For each OSEM 
position (M0 F1 etc), record the serial number of the corresponding AOSEM in the 
SERNUM column in the batch index. 

7. Shade the OSEMs from room light and from each other. 
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8. Measure the open light counts: 
> ../readopenlight 

9. After about 10 seconds, the open light values will appear in a gedit (text editor) window 
titled openlightdata.txt, from where they can be copied and pasted into the OL 
column of the Batch Index spreadsheet. Don’t bother changing the signs to positive. Type 
“q” in the window or click the red close button to close it. The numbers are also available in 
the file openlightdata.txt and could be opened directly with File->Open in Open 
Office. 

10. Enter the date and batch number in the DATE and BATCH columns of the batch index 
against every position that has an AOSEM connected. (This may seem redundant because 
the date will be the same for the whole batch, but it will prove useful when compiling the 
master index later.) Do not use the drag technique as for the DCCNUM column because it 
will increment the dates. Rather, enter the date and batch number against the first AOSEM, 
select all the cells and choose Edit->Fill->Fill Down. 

11. Open the .xml file with DTT:  
> diaggui AOSEM_Batch_Data.xml & 

12. Press Start and wait a minute or two for 10 averages to be taken. Do not bump the AOSEMs 
or cables while data is being taken. 

13. Choose File->Save. 

14. In the Results pane, review the traces for all channels that have AOSEMs connected. They 
should all have a gentle downward slope and be fairly tightly clustered. If there are any 
obvious outliers, check for poor connections or circuit board screws not properly tightened 
and try taking data again. Consider swapping AOSEMs between positions to 
incriminate/exonerate the cables. Be sure to update the SERNUM column in the batch index 
to track any swaps, and to re-shade the AOSEMs after any adjustments. If outliers persist 
after reasonable efforts, then the actual AOSEMs have to be assumed to be faulty. 

15. Resave if adjustments have improved the data. 
16. Save the batch index and quit Open Office. Do not accept any offer to save the file in Open 

Office format - it needs to remain in Excel format so it can be read by Matlab. 
17. Close the DTT window. 

18. Return to the noise directory: 
> cd .. 

19. If there is another batch to test, repeat all the steps in this section. 

3.3 Restoring test stand state 

1. Restore the old MEDM values from the BURT backup generated in Section 3.1, Step 13. 
See the wiki for detailed instructions. 

2. Find the Terminal window with the front end login session from before. 
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3. In the front end directory /opt/rtcds/tst/x1/chans/daq/, delete the minimal 
version of X1SUSQUAD.ini and rename the backup as X1SUSQUAD.ini. 

4. Log into the daqd command line: 
> telnet localhost 8087 

5. Check that you get a prompt daqd> . 

6. Kill the daqd process: 
daqd> shutdown 

7. The daqd process should quit, the telnet session will be terminated, and the daqd process 
should be automatically restarted. 

3.4 Data processing 

The instructions below assume the same Terminal window with the workstation login session on 
the iMac as used above, but with minor adaptations could be done in comfort at the actual 
workstation. 

1. Check that you are in the noise directory and if not, go there:  
> cd /ligo/svncommon/SusSVN/sus/trunk/electronicstesting/AOSEM/noise 

2. Open the master index spreadsheet with Open Office: 
> ooffice AOSEM_Master_Index.xls & 

3. Open Matlab: 
> matlab & 

4.  Open a web browser (it must be one running on the workstation, not the iMac, because 
otherwise it won’t have access to the result files): 

> firefox & 

5.  (Optional) Open a file browser: 
> dolphin & 

6. Do an SVN update to prevent problems with later SVN commits: 
> svn update 

7. Repeat the remaining steps for each batch that has not previously been processed. 
8. Within Open Office, choose File->Open, navigate into the batch directory (2011-10-13-

01 or the like) and select the AOSEM_Batch_Index.xls file. Make a note of the 
number of AOSEMs in the batch. 

20. In Firefox, go to https://dcc.ligo.org/e-traveler/ .  
21. Type S1106179 in the S-Number box at the top of the e-traveler web page. A “Clone _ 

times” box and a “Clone!” button should appear - type the number of AOSEMs in the batch 
in the box and click the button. (S1106179 is a dummy document which will never be part 
of a batch, so enter the full number of AOSEMs rather than the number less one.) 
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22. The e-traveler page will report a list of new S-numbers that have been created. Enter these 
numbers in the DCCNUM column of AOSEM_Batch_Index.xls. Since the numbers 
will normally be sequential, the easiest way to enter all of them is to copy and paste the first 
one, reselect the cell, and then drag the marker at the bottom right corner downwards. Leave 
the e-traveler window open in Firefox. 

9. Copy all the rows with valid data in AOSEM_Batch_Index.xls and paste them at the 
end of the similar list in AOSEM_Master_Index.xls. 

10. Save and close the AOSEM_Batch_Index.xls file. Save the 
AOSEM_Master_Index.xls file but leave it open if there are any more batches to 
process.  

23. Open a new window or tab within Firefox, go to the DCC page for the AOSEM Noise Test 
Data summary document, E1101030 and click the Change Metadata button. 

11. Select and copy the list of new S-numbers from the e-traveler window and paste it at the 
end of the Related Documents field in the E1101030 window. Click Change Metadata 
again. Leave the browser window open. 

12. Within Matlab, generate the result plots: 
>> processbatchdirectory(’2011-10-13-01’) 

13. Review the on-screen plots and check that all the measured curves (blue) are below the 
requirement curves (red). Make a note of the serial numbers of any AOSEMs that fail, and 
remove those AOSEMs from circulation. 

14. (Optional) Within the file browser, navigate into the batch directory, and check that the 
right number of PDF files have been generated. Preview one or two to check that they are 
sensible. 

15. On the browser page for the summary document E1101030, scroll to the end of the Related 
Documents list. Using control-click or the like (command-click on a Mac), open all the new 
S-documents in separate tabs/windows. 

16. In each of the new S-document tabs/windows, click “Upload LIGO-Syynnnnn-v1” and add 
the corresponding PDF plot file. At the same time, adjust the title of the document to 
include the serial number, e.g., “AOSEM” -> “AOSEM SN123”. (There should be no need 
to consult the batch index or master index because both the DCC S-number and the serial 
number are part of the PDF file name.) 

17. In the Terminal window with the workstation login session, look at the contents of the batch 
directory and check for files called core (caused when program crash). If there are any, 
delete them to stop them wasting space in the SVN: 

> ls 2011-10-13-01 

> rm 2011-10-13-01/core 

18. Put the new files under SVN version control. Messages that some items are already under 
version control (from the svn copy command above) can be ignored: 

> svn add 2011-10-13-01 
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19. Upload the batch files and the updated master index to the SVN repository: 
> svn commit -m ”” 

 


